Software that makes simple Markdown content go. Used on bss.zone and other domains of mine.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

186 lines
3.8 KiB

#
# This file is autogenerated by pip-compile with python 3.10
# To update, run:
#
# pip-compile --output-file=requirements/requirements-dev.txt requirements/requirements-dev.in
#
attrs==21.4.0
# via pytest
bandit==1.6.2
# via -r requirements/requirements-dev.in
bleach==4.1.0
# via mdx-linkify
certifi==2021.10.8
# via requests
charset-normalizer==2.0.10
# via requests
click==8.0.3
# via
# flask
# pip-tools
# safety
coverage[toml]==6.2
# via pytest-cov
distlib==0.3.4
# via virtualenv
dlint==0.12.0
# via -r requirements/requirements-dev.in
dparse==0.5.1
# via safety
filelock==3.4.2
# via
# tox
# virtualenv
flake8==4.0.1
# via
# -r requirements/requirements-dev.in
# dlint
# flake8-builtins
# flake8-docstrings
# flake8-executable
# flake8-isort
# flake8-mutable
flake8-blind-except==0.2.0
# via -r requirements/requirements-dev.in
flake8-builtins==1.5.3
# via -r requirements/requirements-dev.in
flake8-docstrings==1.6.0
# via -r requirements/requirements-dev.in
flake8-executable==2.1.1
# via -r requirements/requirements-dev.in
flake8-fixme==1.1.1
# via -r requirements/requirements-dev.in
flake8-isort==4.1.1
# via -r requirements/requirements-dev.in
flake8-logging-format==0.6.0
# via -r requirements/requirements-dev.in
flake8-mutable==1.2.0
# via -r requirements/requirements-dev.in
flask==2.0.2
# via -r requirements/requirements.in
gitdb==4.0.9
# via gitpython
gitpython==3.1.26
# via bandit
idna==3.3
# via requests
iniconfig==1.1.1
# via pytest
isort==5.10.1
# via flake8-isort
itsdangerous==2.0.1
# via flask
jinja2==3.0.3
# via flask
markdown==3.3.6
# via
# -r requirements/requirements.in
# mdx-linkify
markupsafe==2.0.1
# via jinja2
mccabe==0.6.1
# via flake8
mdx-linkify==2.1
# via -r requirements/requirements.in
packaging==21.3
# via
# bleach
# dparse
# pytest
# safety
# tox
pbr==5.8.0
# via stevedore
pep517==0.12.0
# via pip-tools
pip-tools==6.4.0
# via -r requirements/requirements-dev.in
platformdirs==2.4.1
# via virtualenv
pluggy==1.0.0
# via
# pytest
# tox
py==1.11.0
# via
# pytest
# tox
pycodestyle==2.8.0
# via flake8
pydocstyle==6.1.1
# via flake8-docstrings
pydot==1.4.2
# via -r requirements/requirements-dev.in
pyflakes==2.4.0
# via flake8
pyparsing==3.0.6
# via
# packaging
# pydot
pytest==6.2.5
# via
# -r requirements/requirements-dev.in
# pytest-cov
pytest-cov==3.0.0
# via -r requirements/requirements-dev.in
pytz-deprecation-shim==0.1.0.post0
# via tzlocal
pyyaml==6.0
# via
# bandit
# dparse
requests==2.27.1
# via safety
safety==1.10.3
# via -r requirements/requirements-dev.in
six==1.16.0
# via
# bandit
# bleach
# tox
# virtualenv
smmap==5.0.0
# via gitdb
snowballstemmer==2.2.0
# via pydocstyle
stevedore==3.5.0
# via bandit
testfixtures==6.18.3
# via flake8-isort
toml==0.10.2
# via
# dparse
# pytest
# tox
tomli==2.0.0
# via
# coverage
# pep517
tox==3.24.5
# via
# -r requirements/requirements-dev.in
# tox-wheel
tox-wheel==0.7.0
# via -r requirements/requirements-dev.in
tzdata==2021.5
# via pytz-deprecation-shim
tzlocal==4.1
# via -r requirements/requirements.in
urllib3==1.26.8
# via requests
versioneer==0.21
# via -r requirements/requirements-dev.in
virtualenv==20.13.0
# via tox
webencodings==0.5.1
# via bleach
werkzeug==2.0.2
# via flask
wheel==0.37.1
# via
# pip-tools
# tox-wheel
# The following packages are considered to be unsafe in a requirements file:
# pip
# setuptools