Browse Source

version bump (new Django!) and remove twitter lib

master
Brian S. Stephan 10 months ago
parent
commit
75a1b8d7f3
  1. 3
      dr_botzo/settings.py
  2. 109
      requirements/requirements-dev.txt
  3. 1
      requirements/requirements.in
  4. 77
      requirements/requirements.txt

3
dr_botzo/settings.py

@ -95,6 +95,9 @@ DATABASES = {
}
}
# inherited default, look at changing to BigAutoField
DEFAULT_AUTO_FIELD = 'django.db.models.AutoField'
# Internationalization
# https://docs.djangoproject.com/en/1.6/topics/i18n/

109
requirements/requirements-dev.txt

@ -1,10 +1,10 @@
#
# This file is autogenerated by pip-compile
# This file is autogenerated by pip-compile with python 3.8
# To update, run:
#
# pip-compile --output-file=requirements/requirements-dev.txt requirements/requirements-dev.in
#
asgiref==3.2.10
asgiref==3.4.1
# via django
attrs==21.2.0
# via pytest
@ -12,9 +12,9 @@ backports.entry-points-selectable==1.1.0
# via virtualenv
bandit==1.7.0
# via -r requirements/requirements-dev.in
certifi==2020.6.20
certifi==2021.10.8
# via requests
chardet==3.0.4
charset-normalizer==2.0.7
# via requests
click==8.0.3
# via pip-tools
@ -22,18 +22,19 @@ coverage[toml]==6.0.2
# via pytest-cov
distlib==0.3.3
# via virtualenv
django-adminplus==0.5
# via -r requirements/requirements.in
django-bootstrap3==14.2.0
# via -r requirements/requirements.in
django-extensions==3.0.9
# via -r requirements/requirements.in
django==3.1.2
django==3.2.8
# via
# -r requirements/requirements.in
# django-bootstrap3
# django-extensions
# djangorestframework
djangorestframework==3.12.1
django-adminplus==0.5
# via -r requirements/requirements.in
django-bootstrap3==15.0.0
# via -r requirements/requirements.in
django-extensions==3.1.3
# via -r requirements/requirements.in
djangorestframework==3.12.4
# via -r requirements/requirements.in
dlint==0.11.0
# via -r requirements/requirements-dev.in
@ -41,6 +42,15 @@ filelock==3.3.1
# via
# tox
# virtualenv
flake8==3.9.2
# via
# -r requirements/requirements-dev.in
# dlint
# flake8-builtins
# flake8-docstrings
# flake8-executable
# flake8-isort
# flake8-mutable
flake8-blind-except==0.2.0
# via -r requirements/requirements-dev.in
flake8-builtins==1.5.3
@ -57,22 +67,13 @@ flake8-logging-format==0.6.0
# via -r requirements/requirements-dev.in
flake8-mutable==1.2.0
# via -r requirements/requirements-dev.in
flake8==3.9.2
# via
# -r requirements/requirements-dev.in
# dlint
# flake8-builtins
# flake8-docstrings
# flake8-executable
# flake8-isort
# flake8-mutable
gitdb==4.0.9
# via gitpython
gitpython==3.1.24
# via bandit
idna==2.10
idna==3.3
# via requests
inflect==4.1.0
inflect==5.3.0
# via jaraco.itertools
iniconfig==1.1.1
# via pytest
@ -80,35 +81,33 @@ irc==15.0.6
# via -r requirements/requirements.in
isort==5.9.3
# via flake8-isort
jaraco.classes==3.1.0
jaraco.classes==3.2.1
# via jaraco.collections
jaraco.collections==3.0.0
jaraco.collections==3.4.0
# via irc
jaraco.functools==3.0.1
jaraco.functools==3.3.0
# via
# irc
# jaraco.text
# tempora
jaraco.itertools==5.0.0
jaraco.itertools==6.0.3
# via irc
jaraco.logging==3.0.0
jaraco.logging==3.1.0
# via irc
jaraco.stream==3.0.0
jaraco.stream==3.0.3
# via irc
jaraco.text==3.2.0
jaraco.text==3.5.1
# via
# irc
# jaraco.collections
mccabe==0.6.1
# via flake8
more-itertools==8.5.0
more-itertools==8.10.0
# via
# irc
# jaraco.classes
# jaraco.functools
# jaraco.itertools
oauthlib==3.1.0
# via requests-oauthlib
packaging==21.0
# via
# pytest
@ -139,24 +138,24 @@ pydocstyle==6.1.1
# via flake8-docstrings
pyflakes==2.3.1
# via flake8
pyparsing==3.0.1
pyparsing==3.0.2
# via packaging
pytest-cov==3.0.0
# via -r requirements/requirements-dev.in
pytest-django==4.4.0
# via -r requirements/requirements-dev.in
pytest==6.2.5
# via
# -r requirements/requirements-dev.in
# pytest-cov
# pytest-django
python-dateutil==2.8.1
pytest-cov==3.0.0
# via -r requirements/requirements-dev.in
pytest-django==4.4.0
# via -r requirements/requirements-dev.in
python-dateutil==2.8.2
# via -r requirements/requirements.in
python-gitlab==2.5.0
python-gitlab==2.10.1
# via -r requirements/requirements.in
python-mpd2==1.1.0
python-mpd2==3.0.4
# via -r requirements/requirements.in
pytz==2020.1
pytz==2021.3
# via
# -r requirements/requirements.in
# django
@ -164,20 +163,16 @@ pytz==2020.1
# tempora
pyyaml==6.0
# via bandit
requests-oauthlib==1.3.0
# via twython
requests==2.24.0
requests==2.26.0
# via
# python-gitlab
# requests-oauthlib
# twython
six==1.15.0
# requests-toolbelt
requests-toolbelt==0.9.1
# via python-gitlab
six==1.16.0
# via
# bandit
# irc
# jaraco.collections
# jaraco.logging
# jaraco.text
# python-dateutil
# tox
# virtualenv
@ -185,11 +180,11 @@ smmap==5.0.0
# via gitdb
snowballstemmer==2.1.0
# via pydocstyle
sqlparse==0.4.1
sqlparse==0.4.2
# via django
stevedore==3.5.0
# via bandit
tempora==4.0.0
tempora==4.1.2
# via
# irc
# jaraco.logging
@ -203,17 +198,15 @@ tomli==1.2.2
# via
# coverage
# pep517
tox-wheel==0.6.0
# via -r requirements/requirements-dev.in
tox==3.24.4
# via
# -r requirements/requirements-dev.in
# tox-wheel
twython==3.8.2
# via -r requirements/requirements.in
tox-wheel==0.6.0
# via -r requirements/requirements-dev.in
typing-extensions==3.10.0.2
# via gitpython
urllib3==1.25.11
urllib3==1.26.7
# via requests
versioneer==0.21
# via -r requirements/requirements-dev.in

1
requirements/requirements.in

@ -10,5 +10,4 @@ python-dateutil # countdown relative math
python-gitlab # client for the gitlab bot
python-mpd2 # client for mpd
pytz # timezone awareness
twython # twitter client
zalgo-text # zalgoify text

77
requirements/requirements.txt

@ -1,99 +1,92 @@
#
# This file is autogenerated by pip-compile
# This file is autogenerated by pip-compile with python 3.8
# To update, run:
#
# pip-compile --output-file=requirements/requirements.txt requirements/requirements.in
#
asgiref==3.2.10
asgiref==3.4.1
# via django
certifi==2020.6.20
certifi==2021.10.8
# via requests
chardet==3.0.4
charset-normalizer==2.0.7
# via requests
django-adminplus==0.5
# via -r requirements/requirements.in
django-bootstrap3==14.2.0
# via -r requirements/requirements.in
django-extensions==3.0.9
# via -r requirements/requirements.in
django==3.1.2
django==3.2.8
# via
# -r requirements/requirements.in
# django-bootstrap3
# django-extensions
# djangorestframework
djangorestframework==3.12.1
django-adminplus==0.5
# via -r requirements/requirements.in
django-bootstrap3==15.0.0
# via -r requirements/requirements.in
idna==2.10
django-extensions==3.1.3
# via -r requirements/requirements.in
djangorestframework==3.12.4
# via -r requirements/requirements.in
idna==3.3
# via requests
inflect==4.1.0
inflect==5.3.0
# via jaraco.itertools
irc==15.0.6
# via -r requirements/requirements.in
jaraco.classes==3.1.0
jaraco.classes==3.2.1
# via jaraco.collections
jaraco.collections==3.0.0
jaraco.collections==3.4.0
# via irc
jaraco.functools==3.0.1
jaraco.functools==3.3.0
# via
# irc
# jaraco.text
# tempora
jaraco.itertools==5.0.0
jaraco.itertools==6.0.3
# via irc
jaraco.logging==3.0.0
jaraco.logging==3.1.0
# via irc
jaraco.stream==3.0.0
jaraco.stream==3.0.3
# via irc
jaraco.text==3.2.0
jaraco.text==3.5.1
# via
# irc
# jaraco.collections
more-itertools==8.5.0
more-itertools==8.10.0
# via
# irc
# jaraco.functools
# jaraco.itertools
oauthlib==3.1.0
# via requests-oauthlib
parsedatetime==2.6
# via -r requirements/requirements.in
ply==3.11
# via -r requirements/requirements.in
python-dateutil==2.8.1
python-dateutil==2.8.2
# via -r requirements/requirements.in
python-gitlab==2.5.0
python-gitlab==2.10.1
# via -r requirements/requirements.in
python-mpd2==1.1.0
python-mpd2==3.0.4
# via -r requirements/requirements.in
pytz==2020.1
pytz==2021.3
# via
# -r requirements/requirements.in
# django
# irc
# tempora
requests-oauthlib==1.3.0
# via twython
requests==2.24.0
requests==2.26.0
# via
# python-gitlab
# requests-oauthlib
# twython
six==1.15.0
# requests-toolbelt
requests-toolbelt==0.9.1
# via python-gitlab
six==1.16.0
# via
# irc
# jaraco.collections
# jaraco.logging
# jaraco.text
# python-dateutil
sqlparse==0.4.1
sqlparse==0.4.2
# via django
tempora==4.0.0
tempora==4.1.2
# via
# irc
# jaraco.logging
twython==3.8.2
# via -r requirements/requirements.in
urllib3==1.25.11
urllib3==1.26.7
# via requests
zalgo-text==0.6
# via -r requirements/requirements.in

Loading…
Cancel
Save