remove old games-roguelike/angband
the version in the gentoo repo is good by me now
This commit is contained in:
parent
a935a72f2a
commit
f8c2ebf24f
@ -1 +0,0 @@
|
|||||||
DIST angband-4.1.3.tar.gz 19924395 BLAKE2B 573181ab9b3a01abdc34cfac9e69a757eb7558c67c9490240890bc920c6c2a8ebea6268b733f06a6e421829d807fa135131c1512edfc344610a269139cc5ac47 SHA512 7810e1f04e337c1b5d1ddb6013785c953e0149dfa536c75dd8816fdfd304c37a09103d653cee0c150225c6ba702e121300a65012d8034079cd41f86a730f9c2a
|
|
@ -1,107 +0,0 @@
|
|||||||
# Copyright 1999-2019 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=7
|
|
||||||
|
|
||||||
inherit autotools desktop xdg-utils
|
|
||||||
|
|
||||||
MAJOR_PV=$(ver_cut 1-2)
|
|
||||||
|
|
||||||
DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R. Tolkien"
|
|
||||||
HOMEPAGE="https://rephial.org/"
|
|
||||||
SRC_URI="https://rephial.org/downloads/${MAJOR_PV}/${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="GPL-2"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="+ncurses sdl sound +X"
|
|
||||||
|
|
||||||
REQUIRED_USE="sound? ( sdl )
|
|
||||||
|| ( X ncurses )"
|
|
||||||
|
|
||||||
RDEPEND="X? (
|
|
||||||
media-fonts/font-misc-misc
|
|
||||||
x11-libs/libX11
|
|
||||||
)
|
|
||||||
ncurses? ( sys-libs/ncurses:0 )
|
|
||||||
sdl? (
|
|
||||||
media-libs/libsdl[video,X]
|
|
||||||
media-libs/sdl-image
|
|
||||||
media-libs/sdl-ttf
|
|
||||||
sound? (
|
|
||||||
media-libs/libsdl[sound]
|
|
||||||
media-libs/sdl-mixer[mp3]
|
|
||||||
)
|
|
||||||
)"
|
|
||||||
DEPEND="${RDEPEND}"
|
|
||||||
BDEPEND="dev-python/docutils
|
|
||||||
virtual/pkgconfig"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}"/${P}-tinfo.patch
|
|
||||||
"${FILESDIR}"/${P}-gcc-10.patch
|
|
||||||
)
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
default
|
|
||||||
|
|
||||||
sed -i -e '/libpath/s#datarootdir#datadir#' configure.ac || die
|
|
||||||
sed -i -e "/^.SILENT/d" mk/buildsys.mk.in || die
|
|
||||||
sed -i -e '/^DOC =/s/=.*/=/' doc/Makefile || die
|
|
||||||
|
|
||||||
if use !sound ; then
|
|
||||||
sed -i -e 's/sounds//' lib/Makefile || die
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Game constant files are now system config files in Angband, but
|
|
||||||
# users will be hidden from applying updates by default
|
|
||||||
{
|
|
||||||
echo "CONFIG_PROTECT_MASK=\"/etc/${PN}/customize/\""
|
|
||||||
echo "CONFIG_PROTECT_MASK=\"/etc/${PN}/gamedata/\""
|
|
||||||
} > "${T}"/99${PN} || die
|
|
||||||
|
|
||||||
eautoreconf
|
|
||||||
}
|
|
||||||
|
|
||||||
src_configure() {
|
|
||||||
local myconf=(
|
|
||||||
--bindir="${EPREFIX}"/usr/bin
|
|
||||||
--with-private-dirs
|
|
||||||
$(use_enable X x11)
|
|
||||||
$(use_enable sdl)
|
|
||||||
$(use_enable sound sdl-mixer)
|
|
||||||
$(use_enable ncurses curses)
|
|
||||||
)
|
|
||||||
|
|
||||||
econf "${myconf[@]}"
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
default
|
|
||||||
|
|
||||||
dodoc changes.txt faq.txt readme.txt thanks.txt doc/manual.html
|
|
||||||
doenvd "${T}"/99${PN}
|
|
||||||
|
|
||||||
if use X || use sdl ; then
|
|
||||||
use X && make_desktop_entry "angband -mx11" "Angband (X11)" "${PN}"
|
|
||||||
use sdl && make_desktop_entry "angband -msdl" "Angband (SDL)" "${PN}"
|
|
||||||
|
|
||||||
local s
|
|
||||||
for s in 16 32 128 256 512; do
|
|
||||||
newicon -s ${s} lib/icons/att-${s}.png "${PN}.png"
|
|
||||||
done
|
|
||||||
newicon -s scalable lib/icons/att.svg "${PN}.svg"
|
|
||||||
fi
|
|
||||||
}
|
|
||||||
|
|
||||||
pkg_postinst() {
|
|
||||||
if use X || use sdl ; then
|
|
||||||
xdg_icon_cache_update
|
|
||||||
fi
|
|
||||||
}
|
|
||||||
|
|
||||||
pkg_postrm() {
|
|
||||||
if use X || use sdl ; then
|
|
||||||
xdg_icon_cache_update
|
|
||||||
fi
|
|
||||||
}
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -urN angband-4.1.3.orig/src/mon-blows.h angband-4.1.3/src/mon-blows.h
|
|
||||||
--- angband-4.1.3.orig/src/mon-blows.h 2018-07-21 23:49:08.000000000 -0500
|
|
||||||
+++ angband-4.1.3/src/mon-blows.h 2022-01-02 12:04:52.000000000 -0600
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
struct blow_method *next;
|
|
||||||
};
|
|
||||||
|
|
||||||
-struct blow_method *blow_methods;
|
|
||||||
+extern struct blow_method *blow_methods;
|
|
||||||
|
|
||||||
/**
|
|
||||||
* Storage for context information for effect handlers called in
|
|
||||||
@@ -76,7 +76,7 @@
|
|
||||||
struct blow_effect *next;
|
|
||||||
};
|
|
||||||
|
|
||||||
-struct blow_effect *blow_effects;
|
|
||||||
+extern struct blow_effect *blow_effects;
|
|
||||||
|
|
||||||
/* Functions */
|
|
||||||
int blow_index(const char *name);
|
|
@ -1,29 +0,0 @@
|
|||||||
From de53f9644323af0ff084bc82ef17b26aa6db250e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stefan Strogin <stefan.strogin@gmail.com>
|
|
||||||
Date: Thu, 4 Apr 2019 04:24:49 +0300
|
|
||||||
Subject: [PATCH] Link against tinfow or tinfo if needed
|
|
||||||
|
|
||||||
It is needed on systems where libtinfo is separate from libncurses.
|
|
||||||
See: https://bugs.gentoo.org/679942
|
|
||||||
|
|
||||||
Upstream-Status: Submitted [https://github.com/angband/angband/pull/522]
|
|
||||||
Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
|
|
||||||
---
|
|
||||||
configure.ac | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 4a671f33..04fa8cae 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -244,6 +244,7 @@ if test "$enable_curses" = "yes"; then
|
|
||||||
LIBS="${LIBS} -lncursesw"
|
|
||||||
MAINFILES="${MAINFILES} \$(GCUMAINFILES)"
|
|
||||||
])
|
|
||||||
+ AC_SEARCH_LIBS([keypad], [tinfow tinfo])
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user